CVE-2011-4941 — piwik
CVE-2011-4941 is a remote code execution vulnerability in piwik/piwik. A fix is available for piwik/piwik — see the affected versions and patch details below.
Piwik (now Matomo) Vulnerable to Arbitrary Code Execution
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
piwik/piwik🐘matomo/matomoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Unspecified vulnerability in Piwik 1.2 through 1.4 allows remote attackers with the view permission to execute arbitrary code via unknown attack vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | piwik/piwik | ≥ 1.2&&< 1.5 | 1.5composer require piwik/piwik:^1.5 |
| 🐘Packagist | matomo/matomo | ≥ 1.2&&< 1.5 | 1.5composer require matomo/matomo:^1.5 |
Affected Products
matomomatomoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for piwik/piwik, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update piwik/piwik to 1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4941 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2011-4941 in your dependencies?
Find it across Packagist, including transitive dependencies.