NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2013-2191 — python-bugzilla

HIGHFix: python-bugzilla/python-bugzilla@a782282

CVE-2013-2191 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in python-bugzilla. A fix is available for python-bugzilla — see the affected versions and patch details below.

python-bugzilla has improper validation of X.509 certificates

Also known asPYSEC-2014-88
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.93%1.40%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍python-bugzilla

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

python-bugzilla before 0.9.0 does not validate X.509 certificates, which allows man-in-the-middle attackers to spoof Bugzilla servers via a crafted certificate.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpython-bugzillaall versions0.9.0pip install --upgrade 'python-bugzilla==0.9.0'

Affected Products

3 products · 10 configurations
OS
fedorafedoraproject
2 versions
1718
OS
opensuseopensuse
3 versions
11.412.212.3
Application
python-bugzillapython_bugzilla_project
≤ 0.8.0
4 versions
0.6.00.6.10.6.20.7.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-bugzilla, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update python-bugzilla to 0.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2191 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

python-bugzilla before 0.9.0 does not validate X.509 certificates, which allows man-in-the-middle attackers to spoof Bugzilla servers via a crafted certificate.
O3 Security · Impact-Aware SCA

Is CVE-2013-2191 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2013-2191: python-bugzilla — Fixed in 0.9.0