NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2013-1909 — qpid-python

HIGHFix: apache/qpid-python@7d8f517

CVE-2013-1909 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in qpid-python. A fix is available for qpid-python — see the affected versions and patch details below.

Apache Qpid Python client Improper certificate validation

Also known asPYSEC-2013-25
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk+0.25%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.31%0.98%1.66%2.34%0.8%1.8%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍qpid-python

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The Python client in Apache Qpid before 2.2 does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIqpid-pythonall versions0.22pip install --upgrade 'qpid-python==0.22'

Affected Products

2 products · 17 configurations
Application
qpidapache
≤ 0.20
15 versions
0.50.60.70.80.90.100.110.120.130.140.150.16
OS
enterprise mrgredhat
1 version
2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for qpid-python, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update qpid-python to 0.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-1909 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise MRG 2python-qpid-0:0.18-5.el6_4RHSA-2013:1024

Frequently Asked Questions

The Python client in Apache Qpid before 2.2 does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.
O3 Security · Impact-Aware SCA

Is CVE-2013-1909 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2013-1909: qpid-python — Fixed in 0.22