CVE-2013-1397 — symfony
Fix: symfony/symfony@ba6e315CVE-2013-1397 is a Code Injection vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Symfony Arbitrary PHP code Execution
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/yaml🐘symfony/yaml🐘symfony/yamlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Symfony 2.0.x before 2.0.22, 2.1.x before 2.1.7, and 2.2.x remote attackers to execute arbitrary PHP code via a serialized PHP object to the (1) Yaml::parse or (2) Yaml\Parser::parse function, a different vulnerability than CVE-2013-1348.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.2.0-BETA1&&< 2.2.0-BETA2 | 2.2.0-BETA2composer require symfony/symfony:^2.2.0-BETA2 |
| 🐘Packagist | symfony/symfony | ≥ 2.0.0&&< 2.0.22 | 2.0.22composer require symfony/symfony:^2.0.22 |
| 🐘Packagist | symfony/symfony | ≥ 2.1.0&&< 2.1.7 | 2.1.7composer require symfony/symfony:^2.1.7 |
| 🐘Packagist | symfony/yaml | ≥ 2.0.0&&< 2.0.22 | 2.0.22composer require symfony/yaml:^2.0.22 |
| 🐘Packagist | symfony/yaml | ≥ 2.1.0&&< 2.1.7 | 2.1.7composer require symfony/yaml:^2.1.7 |
| 🐘Packagist | symfony/yaml | ≥ 2.2.0-BETA1&&< 2.2.0-BETA2 | 2.2.0-BETA2composer require symfony/yaml:^2.2.0-BETA2 |
Affected Products
symfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.2.0-BETA2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-1397 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2013-1397 in your dependencies?
Find it across Packagist, including transitive dependencies.