CVE-2013-0184 — rack
Fix: rack/rack@1f61549CVE-2013-0184 is a security vulnerability in rack. A fix is available for rack — see the affected versions and patch details below.
Rack vulnerable to Denial of Service
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
rack💎rack💎rack💎rackReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | rack | ≥ 1.1.0&&< 1.1.5 | 1.1.5bundle update rack --conservative |
| 💎RubyGems | rack | ≥ 1.2.0&&< 1.2.7 | 1.2.7bundle update rack --conservative |
| 💎RubyGems | rack | ≥ 1.3.0&&< 1.3.9 | 1.3.9bundle update rack --conservative |
| 💎RubyGems | rack | ≥ 1.4.0&&< 1.4.4 | 1.4.4bundle update rack --conservative |
Affected Products
rackrack_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rack to 1.1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-0184 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| CloudForms for RHEL 6 | rubygem-activesupport-1:3.0.10-10.el6cf | RHSA-2013:0548 |
| Red Hat Subscription Asset Manager 1.2 | apache-commons-codec-0:1.7-2.el6_3 | RHSA-2013:0544 |
Frequently Asked Questions
Is CVE-2013-0184 in your dependencies?
Find it across RubyGems, including transitive dependencies.