CVE-2012-6144 — cms
CVE-2012-6144 is a SQL Injection vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Typo3 Backend History Module Vulnerable to SQL Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
SQL injection vulnerability in the Backend History module in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 Due to missing encoding of user input, the history module is susceptible to SQL Injection and Cross-Site Scripting. A valid backend login is required to exploit this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 4.5.0&&< 4.5.21 | 4.5.21composer require typo3/cms:^4.5.21 |
| 🐘Packagist | typo3/cms | ≥ 4.6.0&&< 4.6.14 | 4.6.14composer require typo3/cms:^4.6.14 |
| 🐘Packagist | typo3/cms | ≥ 4.7.0&&< 4.7.6 | 4.7.6composer require typo3/cms:^4.7.6 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 4.5.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-6144 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2012-6144 in your dependencies?
Find it across Packagist, including transitive dependencies.