NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2012-4968 — framework

Fix: silverstripe/sapphire@0085876

CVE-2012-4968 is a Cross-site Scripting (XSS) vulnerability in silverstripe/framework. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for silverstripe/framework — see the affected versions and patch details below.

Silverstripe XSS Vulnerabilities

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.81%1.62%2.43%0.3%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘silverstripe/framework🐘silverstripe/framework

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe 2.3.x before 2.3.13 and 2.4.x before 2.4.7 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted string to the AbsoluteLinks, (2) BigSummary, (3) ContextSummary, (4) EscapeXML, (5) FirstParagraph, (6) FirstSentence, (7) Initial, (8) LimitCharacters, (9) LimitSentences, (10) LimitWordCount, (11) LimitWordCountXML, (12) Lower, (13) LowerCase, (14) NoHTML, (15) Summary, (16) Upper, (17) UpperCase, or (18) URL method in a template, different vectors than CVE-2012-0976.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsilverstripe/framework≥ 2.3&&< 2.3.132.3.13composer require silverstripe/framework:^2.3.13
🐘Packagistsilverstripe/framework≥ 2.4&&< 2.4.72.4.7composer require silverstripe/framework:^2.4.7

Affected Products

1 product · 19 configurations
Application
silverstripesilverstripe
19 versions
2.3.02.3.12.3.22.3.32.3.42.3.52.3.62.3.72.3.82.3.92.3.102.3.11
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update silverstripe/framework to 2.3.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-4968 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe 2.3.x before 2.3.13 and 2.4.x before 2.4.7 allow remote attackers to inject arbitrary web script or HTML via 1. a crafted string to the `AbsoluteLinks` 1. `BigSummary` 1. `ContextSummary` 1. `EscapeXML` 1. `FirstParagraph` 1. `FirstSentence` 1. `Initial` 1. `LimitCharacters` 1. `LimitSentences` 1. `LimitWordCount` 1. `LimitWordCountXML` 1. `Lower` 1. `LowerCase` 1. `NoHTML` 1. `Summary` 1. `Upper` 1. `UpperCase`, or 1. `URL` method in a template, different vectors than CVE-2012-0976.
O3 Security · Impact-Aware SCA

Is CVE-2012-4968 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2012-4968: framework XSS — Fixed in 2.3.13