CVE-2012-3530 — cms
CVE-2012-3530 is a security vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Typo3 API XSS Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Incomplete blacklist vulnerability in the t3lib_div::quoteJSvalue API function in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain HTML5 JavaScript events.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 4.5&&< 4.5.19 | 4.5.19composer require typo3/cms:^4.5.19 |
| 🐘Packagist | typo3/cms | ≥ 4.6&&< 4.6.12 | 4.6.12composer require typo3/cms:^4.6.12 |
| 🐘Packagist | typo3/cms | ≥ 4.7&&< 4.7.4 | 4.7.4composer require typo3/cms:^4.7.4 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 4.5.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-3530 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2012-3530 in your dependencies?
Find it across Packagist, including transitive dependencies.