CVE-2012-2378 — cxf
CVE-2012-2378 is a CWE-264 vulnerability in org.apache.cxf:cxf. A fix is available for org.apache.cxf:cxf — see the affected versions and patch details below.
Improper Authentication in Apache CXF
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.cxf:cxf☕org.apache.cxf:cxf☕org.apache.cxf:cxfReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache CXF 2.4.5 through 2.4.7, 2.5.1 through 2.5.3, and 2.6.x before 2.6.1, does not properly enforce child policies of a WS-SecurityPolicy 1.1 SupportingToken policy on the client side, which allows remote attackers to bypass the (1) AlgorithmSuite, (2) SignedParts, (3) SignedElements, (4) EncryptedParts, and (5) EncryptedElements policies.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.cxf:cxf | ≥ 2.4.5&&< 2.4.8 | 2.4.8org.apache.cxf:cxf:2.4.8 |
| ☕Maven | org.apache.cxf:cxf | ≥ 2.5.1&&< 2.5.3 | 2.5.3org.apache.cxf:cxf:2.5.3 |
| ☕Maven | org.apache.cxf:cxf | ≥ 2.6.0&&< 2.6.1 | 2.6.1org.apache.cxf:cxf:2.6.1 |
Affected Products
cxfapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.cxf:cxf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.cxf:cxf to 2.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-2378 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss Enterprise Application Platform 6.0 | see advisory | RHSA-2012:1594 |
| Red Hat JBoss Enterprise Application Platform 6 for RHEL 5 | antlr-eap6-0:2.7.7-15_redhat_2.ep6.el5 | RHSA-2012:1591 |
| Red Hat JBoss Enterprise Application Platform 6 for RHEL 6 | antlr-eap6-0:2.7.7-15_redhat_2.ep6.el6 | RHSA-2012:1592 |
Frequently Asked Questions
Is CVE-2012-2378 in your dependencies?
Find it across Maven, including transitive dependencies.