NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2012-2112 — cms

CVE-2012-2112 is a Cross-site Scripting (XSS) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.

Typo3 Exception Handler XSS

Published
Updated
Affected
4 pkgs
Patched
3 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.63%1.26%1.89%0.5%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐘typo3/cms🐘typo3/cms🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the Exception Handler in TYPO3 4.4.x before 4.4.15, 4.5.x before 4.5.15, 4.6.x before 4.6.8, and 4.7 allows remote attackers to inject arbitrary web script or HTML via exception messages.

Affected Packages

4 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms≥ 4.4&&< 4.4.154.4.15composer require typo3/cms:^4.4.15
🐘Packagisttypo3/cms≥ 4.5&&< 4.5.154.5.15composer require typo3/cms:^4.5.15
🐘Packagisttypo3/cms≥ 4.6&&< 4.6.84.6.8composer require typo3/cms:^4.6.8
🐘Packagisttypo3/cmsall versionsNo fix

Affected Products

1 product · 39 configurations
Application
typo3typo3
39 versions
4.4.04.4.14.4.24.4.34.4.44.4.54.4.64.4.74.4.84.4.94.4.104.4.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms to 4.4.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-2112 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the Exception Handler in TYPO3 4.4.x before 4.4.15, 4.5.x before 4.5.15, 4.6.x before 4.6.8, and 4.7 allows remote attackers to inject arbitrary web script or HTML via exception messages.
O3 Security · Impact-Aware SCA

Is CVE-2012-2112 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2012-2112: cms XSS — Fixed in 4.4.15