NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2012-20001 — prestashop

MEDIUM

CVE-2012-20001 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in prestashop/prestashop. A fix is available for prestashop/prestashop — see the affected versions and patch details below.

PrestaShop XSS Vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.88%1.32%0.4%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘prestashop/prestashop

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

PrestaShop before 1.5.2.0 allows XSS via the <object data='data:text/html substring in the message field.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistprestashop/prestashopall versions1.5.2.0composer require prestashop/prestashop:^1.5.2.0

Affected Products

1 product · 1 configurations
Application
prestashopprestashop
< 1.5.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/prestashop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update prestashop/prestashop to 1.5.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-20001 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

PrestaShop before 1.5.2.0 allows XSS via the `<object data='data:text/html` substring in the message field.
O3 Security · Impact-Aware SCA

Is CVE-2012-20001 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2012-20001: prestashop XSS — Fixed in 1.5.2.0