NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2012-1605 — cms

CVE-2012-1605 is a remote code execution vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.

Typo3 Extbase Framework Unsafe Deserialization

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.44%1.25%2.06%2.87%0.9%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
🐘typo3/cms🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Extbase Framework in TYPO3 4.6.x through 4.6.6, 4.7, and 6.0 unserializes untrusted data, which allows remote attackers to unserialize arbitrary objects and possibly execute arbitrary code via vectors related to "a missing signature (HMAC) for a request argument."

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms≥ 4.6&&< 4.6.74.6.7composer require typo3/cms:^4.6.7
🐘Packagisttypo3/cms≥ 4.4.0&&< 4.4.144.4.14composer require typo3/cms:^4.4.14
🐘Packagisttypo3/cms≥ 4.5.0&&< 4.5.144.5.14composer require typo3/cms:^4.5.14

Affected Products

1 product · 10 configurations
Application
typo3typo3
10 versions
4.64.6.04.6.14.6.24.6.34.6.44.6.54.6.64.76.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms to 4.6.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-1605 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The Extbase Framework in TYPO3 4.6.x through 4.6.6, 4.7, and 6.0 unserializes untrusted data, which allows remote attackers to unserialize arbitrary objects and possibly execute arbitrary code via vectors related to "a missing signature (HMAC) for a request argument."
O3 Security · Impact-Aware SCA

Is CVE-2012-1605 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2012-1605: cms RCE — Fixed in 4.6.7