NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2012-0878 — pastescript

MEDIUMFix: cdent/pastescript@b5f36f2

CVE-2012-0878 is a medium-severity (CVSS 6.5) CWE-264 vulnerability in pastescript. A fix is available for pastescript — see the affected versions and patch details below.

Paste Script has improper group memberships permissions

Also known asGHSA-27px-qpmj-qg38PYSEC-2012-15PYSEC-2026-2859
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.40%1.89%3.39%4.88%1.2%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍pastescript🐍paste

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Paste Script 1.7.5 and earlier does not properly set group memberships during execution with root privileges, which might allow remote attackers to bypass intended file-access restrictions by leveraging a web application that uses the local filesystem.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpastescriptall versions2.0.1pip install --upgrade 'pastescript==2.0.1'
🐍PyPIpasteall versions1.7.5.1pip install --upgrade 'paste==1.7.5.1'

Affected Products

1 product · 1 configurations
Application
pastepythonpaste
≤ 1.7.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pastescript, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pastescript to 2.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-0878 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 6python-paste-script-0:1.7.3-5.el6_3RHSA-2012:1206

Frequently Asked Questions

Paste Script 1.7.5 and earlier does not properly set group memberships during execution with root privileges, which might allow remote attackers to bypass intended file-access restrictions by leveraging a web application that uses the local filesystem.
O3 Security · Impact-Aware SCA

Is CVE-2012-0878 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2012-0878: pastescript — Fixed in 2.0.1