NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2010-2477 — paste

MEDIUMFix: cdent/paste@4910493

CVE-2010-2477 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in paste. A fix is available for paste — see the affected versions and patch details below.

Paste is vulnerable to Cross-site Scripting via vectors involving a 404 status code

Also known asGHSA-7gfc-2v6g-6w9fPYSEC-2010-29
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.94%1.88%2.82%0.5%2.3%May 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍paste

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in the paste.httpexceptions implementation in Paste before 1.7.4 allow remote attackers to inject arbitrary web script or HTML via vectors involving a 404 status code, related to (1) paste.urlparser.StaticURLParser, (2) paste.urlparser.PkgResourcesParser, (3) paste.urlmap.URLMap, and (4) HTTPNotFound.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpasteall versions1.7.4pip install --upgrade 'paste==1.7.4'

Affected Products

1 product · 22 configurations
Application
pastepythonpaste
≤ 1.7.3.1
21 versions
0.1.00.30.4.10.50.9.10.9.20.9.30.9.41.0.11.11.1.11.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for paste, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update paste to 1.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-2477 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in the paste.httpexceptions implementation in Paste before 1.7.4 allow remote attackers to inject arbitrary web script or HTML via vectors involving a 404 status code, related to (1) paste.urlparser.StaticURLParser, (2) paste.urlparser.PkgResourcesParser, (3) paste.urlmap.URLMap, and (4) HTTPNotFound.
O3 Security · Impact-Aware SCA

Is CVE-2010-2477 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2010-2477: paste XSS — Fixed in 1.7.4