NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2011-5034 — geronimo

CVE-2011-5034 is a Improper Input Validation vulnerability in org.apache.geronimo:geronimo. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.geronimo:geronimo — see the affected versions and patch details below.

Apache Geronimo Hash Collisions Cause DoS

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
80.6%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
71.0%75.2%79.3%83.5%73.3%80.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.apache.geronimo:geronimo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Geronimo 2.2.1 and earlier computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters. NOTE: this might overlap CVE-2011-4461.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.geronimo:geronimoall versions2.2.1org.apache.geronimo:geronimo:2.2.1

Affected Products

1 product · 17 configurations
Application
geronimoapache
≤ 2.2.1
16 versions
1.01.11.1.11.22.0.12.0.22.12.1.12.1.22.1.32.1.42.1.5
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-2012webappsphp✓ Verified

MyBulletinBoard (MyBB) 1.1.5 - 'CLIENT-IP' SQL Injection

by rgod · Jul 15, 2006

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.geronimo:geronimo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.geronimo:geronimo to 2.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-5034 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Apache Geronimo 2.2.1 and earlier computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters. NOTE: this might overlap CVE-2011-4461.
O3 Security · Impact-Aware SCA

Is CVE-2011-5034 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2011-5034: geronimo DoS — Fixed in 2.2.1