NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2011-4632 — cms

MEDIUM

CVE-2011-4632 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.

Typo3 XSS Vulnerabilities

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.79%1.18%0.2%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘typo3/cms🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site Scripting (XSS) in TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to inject arbitrary web script or HTML via the tcemain flash message.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cmsall versions4.3.12composer require typo3/cms:^4.3.12
🐘Packagisttypo3/cms≥ 4.4.0&&< 4.4.94.4.9composer require typo3/cms:^4.4.9
🐘Packagisttypo3/cms≥ 4.5.0&&< 4.5.44.5.4composer require typo3/cms:^4.5.4

Affected Products

1 product · 3 configurations
Application
typo3typo3
≥ 4.5.0 && < 4.5.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms to 4.3.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4632 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) in TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to inject arbitrary web script or HTML via the tcemain flash message.
O3 Security · Impact-Aware SCA

Is CVE-2011-4632 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2011-4632: cms XSS — Fixed in 4.3.12