CVE-2011-2730 — spring-core
Fix: spring-projects/spring-framework@62ccc8dCVE-2011-2730 is a CWE-16 vulnerability in org.springframework:spring-core. EPSS puts its 30-day exploitation probability at 11.8% (96th percentile). A fix is available for org.springframework:spring-core — see the affected versions and patch details below.
Improper Neutralization of Directives in Dynamically Evaluated Code in Spring Framework
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.springframework:spring-core☕org.springframework:spring-core☕org.springframework:spring-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
VMware SpringSource Spring Framework before 2.5.6.SEC03, 2.5.7.SR023, and 3.x before 3.0.6, when a container supports Expression Language (EL), evaluates EL expressions in tags twice, which allows remote attackers to obtain sensitive information via a (1) name attribute in a (a) spring:hasBindErrors tag; (2) path attribute in a (b) spring:bind or (c) spring:nestedpath tag; (3) arguments, (4) code, (5) text, (6) var, (7) scope, or (8) message attribute in a (d) spring:message or (e) spring:theme tag; or (9) var, (10) scope, or (11) value attribute in a (f) spring:transform tag, aka "Expression Language Injection."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework:spring-core | ≥ 3.0.0&&< 3.0.6 | 3.0.6org.springframework:spring-core:3.0.6 |
| ☕Maven | org.springframework:spring-core | all versions | 2.5.6.SEC03org.springframework:spring-core:2.5.6.SEC03 |
| ☕Maven | org.springframework:spring-core | ≥ 2.5.7.SR0&&< 2.5.7.SR023 | 2.5.7.SR023org.springframework:spring-core:2.5.7.SR023 |
Affected Products
spring frameworkspringsourceDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.springframework:spring-core to 3.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-2730 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This flaw was originally reported as resulting in information disclosure only, and was therefore assessed as having low security impact. On this basis, it was planned that future updates to JBoss products may address this flaw. New research [0] has now shown that this flaw can lead to remote code execution. The…
| Product | Fixed in | Advisory |
|---|---|---|
| JBEWP 5 for RHEL 5 | aopalliance-0:1.0-5.2.jdk6.ep5.el5 | RHSA-2013:0196 |
| JBEWP 5 for RHEL 6 | aopalliance-0:1.0-5.3.ep5.el6 | RHSA-2013:0195 |
| JBoss Enterprise BRMS Platform 5.3 | see advisory | RHSA-2013:0221 |
| Red Hat JBoss Enterprise Application Platform 5.2 | see advisory | RHSA-2013:0194 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 5 | aopalliance-0:1.0-5.2.jdk6.ep5.el5 | RHSA-2013:0192 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 6 | aopalliance-0:1.0-5.3.ep5.el6 | RHSA-2013:0191 |
| Red Hat JBoss Portal 5.2 | see advisory | RHSA-2013:0953 |
| Red Hat JBoss SOA Platform 5.3 | see advisory | RHSA-2013:0533 |
Frequently Asked Questions
Is CVE-2011-2730 in your dependencies?
Find it across Maven, including transitive dependencies.