NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2011-1028 — smarty

CRITICALFix: smarty-php/smarty@0154f17

CVE-2011-1028 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in smarty/smarty. A fix is available for smarty/smarty — see the affected versions and patch details below.

Smarty3 Arbitrary PHP Code Execution

Also known asGHSA-6frx-2r5w-c524
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.02%0.72%1.41%2.11%0.5%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘smarty/smarty

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The $smarty.template variable in Smarty3 allows attackers to possibly execute arbitrary PHP code via the sysplugins/smarty_internal_compile_private_special_variable.php file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsmarty/smartyall versions3.0.7composer require smarty/smarty:^3.0.7

Affected Products

2 products · 4 configurations
OS
debian linuxdebian
3 versions
8.09.010.0
Application
smartysmarty
≥ 3.0.0 && < 3.0.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for smarty/smarty, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update smarty/smarty to 3.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-1028 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The $smarty.template variable in Smarty3 allows attackers to possibly execute arbitrary PHP code via the sysplugins/smarty_internal_compile_private_special_variable.php file.
O3 Security · Impact-Aware SCA

Is CVE-2011-1028 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2011-1028: smarty — Fixed in 3.0.7