CVE-2010-3714 — cms
Fix: TYPO3/typo3@687b671CVE-2010-3714 is a CWE-264 vulnerability in typo3/cms. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for typo3/cms — see the affected versions and patch details below.
TYPO3 Remote File Disclosure vulnerability in the jumpUrl mechanism
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The jumpUrl (aka access tracking) implementation in tslib/class.tslib_fe.php in TYPO3 4.2.x before 4.2.15, 4.3.x before 4.3.7, and 4.4.x before 4.4.4 does not properly compare certain hash values during access-control decisions, which allows remote attackers to read arbitrary files via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 4.2.0&&< 4.2.15 | 4.2.15composer require typo3/cms:^4.2.15 |
| 🐘Packagist | typo3/cms | ≥ 4.3.0&&< 4.3.7 | 4.3.7composer require typo3/cms:^4.3.7 |
| 🐘Packagist | typo3/cms | ≥ 4.4.0&&< 4.4.4 | 4.4.4composer require typo3/cms:^4.4.4 |
Affected Products
typo3typo3Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
TYPO3 - Arbitrary File Retrieval
by ikki · Dec 29, 2010
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 4.2.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3714 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2010-3714 in your dependencies?
Find it across Packagist, including transitive dependencies.