NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2010-3700 — spring-security-core

CVE-2010-3700 is a CWE-264 vulnerability in org.springframework.security:spring-security-core. A fix is available for org.springframework.security:spring-security-core — see the affected versions and patch details below.

Authentication Bypass Using an Alternate Path or Channel in SpringSource Spring Security and Acegi Security

Published
Updated
Affected
3 pkgs
Patched
2 / 3
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.73%1.46%2.19%0.2%1.7%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-core☕org.acegisecurity:acegi-security

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

VMware SpringSource Spring Security 2.x before 2.0.6 and 3.x before 3.0.4, and Acegi Security 1.0.0 through 1.0.7, as used in IBM WebSphere Application Server (WAS) 6.1 and 7.0, allows remote attackers to bypass security constraints via a path parameter.

Affected Packages

3 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.security:spring-security-core≥ 2.0.0&&< 2.0.62.0.6org.springframework.security:spring-security-core:2.0.6
☕Mavenorg.springframework.security:spring-security-core≥ 3.0.0&&< 3.0.43.0.4org.springframework.security:spring-security-core:3.0.4
☕Mavenorg.acegisecurity:acegi-security≥ 1.0.0No fix

Affected Products

3 products · 20 configurations
Application
acegi-securityacegisecurity
8 versions
1.0.01.0.11.0.21.0.31.0.41.0.51.0.61.0.7
Application
websphere application serveribm
2 versions
6.17.0
Application
springsource spring securityvmware
10 versions
2.0.02.0.12.0.22.0.32.0.42.0.53.0.03.0.13.0.23.0.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.security:spring-security-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.security:spring-security-core to 2.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3700 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

VMware SpringSource Spring Security 2.x before 2.0.6 and 3.x before 3.0.4, and Acegi Security 1.0.0 through 1.0.7, as used in IBM WebSphere Application Server (WAS) 6.1 and 7.0, allows remote attackers to bypass security constraints via a path parameter.
O3 Security · Impact-Aware SCA

Is CVE-2010-3700 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2010-3700: spring-security-core — Fixed in 2.0.6