NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2010-3663 — cms-backend

HIGH

CVE-2010-3663 is a high-severity (CVSS 8.8) Unrestricted File Upload vulnerability in typo3/cms-backend. A fix is available for typo3/cms-backend — see the affected versions and patch details below.

TYPO3 Arbitrary Code Execution vulnerability on the backend

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
1.89%2.43%2.96%3.49%3.0%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backend

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 contains an insecure default value of the variable fileDenyPattern which could allow remote attackers to execute arbitrary code on the backend.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-backendall versions4.1.14composer require typo3/cms-backend:^4.1.14
🐘Packagisttypo3/cms-backend≥ 4.2&&< 4.2.134.2.13composer require typo3/cms-backend:^4.2.13
🐘Packagisttypo3/cms-backend≥ 4.3&&< 4.3.44.3.4composer require typo3/cms-backend:^4.3.4
🐘Packagisttypo3/cms-backend≥ 4.4&&< 4.4.14.4.1composer require typo3/cms-backend:^4.4.1

Affected Products

1 product · 4 configurations
Application
typo3typo3
≥ 4.4.0 && < 4.4.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-backend to 4.1.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3663 is resolved across your whole dependency graph.

  3. Workarounds

    Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.

Frequently Asked Questions

TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 contains an insecure default value of the variable fileDenyPattern which could allow remote attackers to execute arbitrary code on the backend.
O3 Security · Impact-Aware SCA

Is CVE-2010-3663 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2010-3663: cms-backend RCE — Fixed in 4.1.14