CVE-2025-59019 — cms-backend
Fix: TYPO3-CMS/backend@c983415CVE-2025-59019 is a Information Exposure vulnerability in typo3/cms-backend. A fix is available for typo3/cms-backend — see the affected versions and patch details below.
Information Disclosure via CSV Download
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-59019.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-recordlistReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Missing authorization checks in the CSV download feature of TYPO3 CMS versions 11.0.0‑11.5.47, 12.0.0‑12.4.36, and 13.0.0‑13.4.17 allow backend users to disclose information from arbitrary database tables stored within the users' web mounts without having access to them.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-backend | ≥ 12.0.0&&< 12.4.37 | 12.4.37composer require typo3/cms-backend:^12.4.37 |
| 🐘Packagist | typo3/cms-backend | ≥ 13.0.0&&< 13.4.18 | 13.4.18composer require typo3/cms-backend:^13.4.18 |
| 🐘Packagist | typo3/cms-recordlist | ≥ 11.0.0&&< 12.4.37 | 12.4.37composer require typo3/cms-recordlist:^12.4.37 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-backend to 12.4.37 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-59019 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-59019 in your dependencies?
Find it across Packagist, including transitive dependencies.