NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2010-3662 — cms-backend

HIGH

CVE-2010-3662 is a high-severity (CVSS 8.8) SQL Injection vulnerability in typo3/cms-backend. A fix is available for typo3/cms-backend — see the affected versions and patch details below.

TYPO3 SQL injection vulnerability on the backend

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.56%1.12%1.69%0.4%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backend

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows SQL Injection on the backend.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-backendall versions4.1.14composer require typo3/cms-backend:^4.1.14
🐘Packagisttypo3/cms-backend≥ 4.2.0&&< 4.2.134.2.13composer require typo3/cms-backend:^4.2.13
🐘Packagisttypo3/cms-backend≥ 4.3.0&&< 4.3.44.3.4composer require typo3/cms-backend:^4.3.4
🐘Packagisttypo3/cms-backend≥ 4.4.0&&< 4.4.14.4.1composer require typo3/cms-backend:^4.4.1

Affected Products

1 product · 4 configurations
Application
typo3typo3
≥ 4.4.0 && < 4.4.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-backend to 4.1.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3662 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows SQL Injection on the backend.
O3 Security · Impact-Aware SCA

Is CVE-2010-3662 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2010-3662: cms-backend — Fixed in 4.1.14