CVE-2010-3659 — cms-backend
MEDIUMCVE-2010-3659 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in typo3/cms-backend. A fix is available for typo3/cms-backend — see the affected versions and patch details below.
TYPO3 Cross-site Scripting vulnerability in the extension manager and backend forms
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backendReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site scripting (XSS) vulnerabilities in TYPO3 CMS 4.1.x before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4, and 4.4.x before 4.4.1 allow remote authenticated backend users to inject arbitrary web script or HTML via unspecified parameters to the extension manager, or unspecified parameters to unknown backend forms.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-backend | ≥ 4.1.0&&< 4.1.14 | 4.1.14composer require typo3/cms-backend:^4.1.14 |
| 🐘Packagist | typo3/cms-backend | ≥ 4.2.0&&< 4.2.13 | 4.2.13composer require typo3/cms-backend:^4.2.13 |
| 🐘Packagist | typo3/cms-backend | ≥ 4.3.0&&< 4.3.4 | 4.3.4composer require typo3/cms-backend:^4.3.4 |
| 🐘Packagist | typo3/cms-backend | ≥ 4.4.0&&< 4.4.1 | 4.4.1composer require typo3/cms-backend:^4.4.1 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-backend to 4.1.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3659 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2010-3659 in your dependencies?
Find it across Packagist, including transitive dependencies.