CVE-2010-3198 is a high-severity (CVSS 7.5) vulnerability in zope. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zope — see the affected versions and patch details below.
Zope Denial of Service (DoS) vulnerability in ZServer
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
zope🐍zopeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
ZServer in Zope 2.10.x before 2.10.12 and 2.11.x before 2.11.7 allows remote attackers to cause a denial of service (crash of worker threads) via vectors that trigger uncaught exceptions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | zope | ≥ 2.10.0&&< 2.10.12 | 2.10.12pip install --upgrade 'zope==2.10.12' |
| 🐍PyPI | zope | ≥ 2.11.0&&< 2.11.7 | 2.11.7pip install --upgrade 'zope==2.11.7' |
Affected Products
zopezopeResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zope, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zope to 2.10.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3198 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2010-3198 in your dependencies?
Find it across PyPI, including transitive dependencies.