NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2009-5065 — feedparser

MEDIUM

CVE-2009-5065 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in feedparser. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for feedparser — see the affected versions and patch details below.

feedparser Cross-site Scripting vulnerability

Also known asGHSA-3mwg-gp5g-fv3qPYSEC-2011-18
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
3.74%5.14%6.55%7.96%7.2%4.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍feedparser

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0 allows remote attackers to inject arbitrary web script or HTML via vectors involving nested CDATA stanzas.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIfeedparserall versions5.0pip install --upgrade 'feedparser==5.0'

Affected Products

1 product · 9 configurations
Application
feedparsermark_pilgrim
≤ 4.1
8 versions
3.03.0.13.13.23.34.04.0.14.0.2
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-35570remotemultiple✓ Verified

python-feedparser 5.0 - '/feedparser/feedparser.py' Cross-Site Scripting

by fazalmajid · Apr 5, 2011

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for feedparser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update feedparser to 5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-5065 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0 allows remote attackers to inject arbitrary web script or HTML via vectors involving nested CDATA stanzas.
O3 Security · Impact-Aware SCA

Is CVE-2009-5065 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2009-5065: feedparser XSS — Fixed in 5.0