NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2009-5054 — smarty

CVE-2009-5054 is a CWE-264 vulnerability in smarty/smarty. A fix is available for smarty/smarty — see the affected versions and patch details below.

Smarty Does Not Consider Umask Values When Setting Permissions

Also known asGHSA-6m9f-8vwq-97pm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.70%1.39%2.09%0.1%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘smarty/smarty

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Smarty before 3.0.0 beta 4 does not consider the umask value when setting the permissions of files, which might allow attackers to bypass intended access restrictions via standard filesystem operations.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsmarty/smartyall versions3.0.0-beta4composer require smarty/smarty:^3.0.0-beta4

Affected Products

1 product · 61 configurations
Application
smartysmarty
≤ 2.6.26
53 versions
1.01.0a1.0b1.1.01.2.01.2.11.2.21.3.01.3.11.3.21.4.01.4.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for smarty/smarty, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update smarty/smarty to 3.0.0-beta4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-5054 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Smarty before 3.0.0 beta 4 does not consider the umask value when setting the permissions of files, which might allow attackers to bypass intended access restrictions via standard filesystem operations.
O3 Security · Impact-Aware SCA

Is CVE-2009-5054 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2009-5054: smarty — Fixed in 3.0.0-beta4