NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2009-4159 — direct-mail

CVE-2009-4159 is a Cross-site Scripting (XSS) vulnerability in directmailteam/direct-mail. A fix is available for directmailteam/direct-mail — see the affected versions and patch details below.

TYPO3 Direct Mail Extension Vulnerable to Cross-Site Scripting (XSS)

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.89%1.34%0.2%0.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘directmailteam/direct-mail

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the newsletter configuration feature in the backend module in the Direct Mail (direct_mail) extension 2.6.4 and earlier for TYPO3 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdirectmailteam/direct-mailall versions2.6.5composer require directmailteam/direct-mail:^2.6.5

Affected Products

1 product · 12 configurations
Application
direct mailivan_kartolo
≤ 2.6.4
11 versions
2.0.02.0.12.1.12.1.22.1.42.1.52.5.02.6.02.6.12.6.22.6.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for directmailteam/direct-mail, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update directmailteam/direct-mail to 2.6.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-4159 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the newsletter configuration feature in the backend module in the Direct Mail (direct_mail) extension 2.6.4 and earlier for TYPO3 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2009-4159 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2009-4159: direct-mail XSS — Fixed in 2.6.5