NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2009-3630 — cms-backend

CVE-2009-3630 is a security vulnerability in typo3/cms-backend. A fix is available for typo3/cms-backend — see the affected versions and patch details below.

TYPO3 Backend vulnerable to Frame Hijacking

Published
Updated
Affected
4 pkgs
Patched
3 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.45%1.12%1.80%2.48%0.9%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐘typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backend

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote authenticated users to place arbitrary web sites in TYPO3 backend framesets via crafted parameters, related to a "frame hijacking" issue.

Affected Packages

4 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-backendall versionsNo fix
🐘Packagisttypo3/cms-backend≥ 4.1.0&&< 4.1.134.1.13composer require typo3/cms-backend:^4.1.13
🐘Packagisttypo3/cms-backend≥ 4.2.0&&< 4.2.104.2.10composer require typo3/cms-backend:^4.2.10
🐘Packagisttypo3/cms-backend≥ 4.3alpha1&&< 4.3beta24.3beta2composer require typo3/cms-backend:^4.3beta2

Affected Products

1 product · 59 configurations
Application
typo3typo3
≤ 4.0.12
55 versions
0.1.21.0.141.11.1.11.1.091.1.101.2.01.3.01.3.23.03.3.x3.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2009-3630; check the affected-versions list above or the advisory for the patched release of typo3/cms-backend, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote authenticated users to place arbitrary web sites in TYPO3 backend framesets via crafted parameters, related to a "frame hijacking" issue.
O3 Security · Impact-Aware SCA

Is CVE-2009-3630 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2009-3630: cms-backend — Fixed in 4.1.13