NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2009-3629 — cms-backend

CVE-2009-3629 is a Cross-site Scripting (XSS) vulnerability in typo3/cms-backend. A fix is available for typo3/cms-backend — see the affected versions and patch details below.

TYPO3 Backend vulnerable to Cross-site Scripting

Published
Updated
Affected
4 pkgs
Patched
3 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.68%1.36%2.04%0.3%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐘typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backend🐘typo3/cms-backend

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in the Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

4 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-backendall versionsNo fix
🐘Packagisttypo3/cms-backend≥ 4.1.0&&< 4.1.134.1.13composer require typo3/cms-backend:^4.1.13
🐘Packagisttypo3/cms-backend≥ 4.2.0&&< 4.2.104.2.10composer require typo3/cms-backend:^4.2.10
🐘Packagisttypo3/cms-backend≥ 4.3alpha1&&< 4.3beta24.3beta2composer require typo3/cms-backend:^4.3beta2

Affected Products

1 product · 46 configurations
Application
typo3typo3
≤ 4.0.13
40 versions
4.04.0.14.0.24.0.34.0.44.0.54.0.64.0.74.0.84.0.94.0.104.0.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2009-3629; check the affected-versions list above or the advisory for the patched release of typo3/cms-backend, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in the Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2009-3629 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2009-3629: cms-backend XSS — Fixed in 4.1.13