NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2009-0816 — cms

CVE-2009-0816 is a Cross-site Scripting (XSS) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.

Typo3 Backend XSS Vulnerability

Published
Updated
Affected
5 pkgs
Patched
3 / 5
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.00%0.52%1.04%1.56%0.3%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

5 pkgs affected
🐘typo3/cms🐘typo3/cms🐘typo3/cms🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An Information Disclosure vulnerability in jumpUrl mechanism, used to track access on web pages and provided files, allows a remote attacker to read arbitrary files on a host.

The expected value of a mandatory hash secret, intended to invalidate such requests, is exposed to remote users allowing them to bypass access control by providing the correct value.

There's no authentication required to exploit this vulnerability. The vulnerability allows to read any file, the web server user account has access to.

Affected Packages

5 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms≥ 3.3.0No fix
🐘Packagisttypo3/cms≥ 4.0&&< 4.0.124.0.12composer require typo3/cms:^4.0.12
🐘Packagisttypo3/cms≥ 4.1.0&&< 4.1.104.1.10composer require typo3/cms:^4.1.10
🐘Packagisttypo3/cms≥ 4.2.0&&< 4.2.64.2.6composer require typo3/cms:^4.2.6
🐘Packagisttypo3/cmsall versionsNo fix

Affected Products

1 product · 28 configurations
Application
typo3typo3
28 versions
4.04.0.14.0.24.0.34.0.44.0.54.0.64.0.74.0.84.0.94.0.104.0.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2009-0816; check the affected-versions list above or the advisory for the patched release of typo3/cms, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An Information Disclosure vulnerability in jumpUrl mechanism, used to track access on web pages and provided files, allows a remote attacker to read arbitrary files on a host. The expected value of a mandatory hash secret, intended to invalidate such requests, is exposed to remote users allowing them to bypass access control by providing the correct value. There's no authentication required to exploit this vulnerability. The vulnerability allows to read any file, the web server user account has access to.
O3 Security · Impact-Aware SCA

Is CVE-2009-0816 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2009-0816: cms Info Disclosure — Fixed in 4.0.12