NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2009-0256 — cms

CVE-2009-0256 is a Improper Authentication vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.

Authentication library in TYPO3 vulnerable to session fixation

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.41%1.04%1.67%2.29%0.9%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
🐘typo3/cms🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Session fixation vulnerability in the authentication library in TYPO3 4.0.0 through 4.0.9, 4.1.0 through 4.1.7, and 4.2.0 through 4.2.3 allows remote attackers to hijack web sessions via unspecified vectors related to (1) frontend and (2) backend authentication.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms≥ 4.0.0&&< 4.0.104.0.10composer require typo3/cms:^4.0.10
🐘Packagisttypo3/cms≥ 4.1.0&&< 4.1.84.1.8composer require typo3/cms:^4.1.8
🐘Packagisttypo3/cms≥ 4.2.0&&< 4.2.44.2.4composer require typo3/cms:^4.2.4

Affected Products

1 product · 24 configurations
Application
typo3typo3
22 versions
4.04.0.14.0.24.0.34.0.44.0.54.0.64.0.74.0.84.0.94.1.04.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms to 4.0.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-0256 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Session fixation vulnerability in the authentication library in TYPO3 4.0.0 through 4.0.9, 4.1.0 through 4.1.7, and 4.2.0 through 4.2.3 allows remote attackers to hijack web sessions via unspecified vectors related to (1) frontend and (2) backend authentication.
O3 Security · Impact-Aware SCA

Is CVE-2009-0256 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2009-0256: cms — Fixed in 4.0.10