CVE-2008-6547 — formencode
HIGHCVE-2008-6547 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in formencode. A fix is available for formencode — see the affected versions and patch details below.
FormEncode Access Restrictions Bypass
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
formencodeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
schema.py in FormEncode for Python (python-formencode) 1.0 does not apply the chained_validators feature, which allows attackers to bypass intended access restrictions via unknown vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | formencode | ≥ 1.0&&< 1.0.1 | 1.0.1pip install --upgrade 'formencode==1.0.1' |
Affected Products
formencodeformencodeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for formencode, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update formencode to 1.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-6547 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2008-6547 in your dependencies?
Find it across PyPI, including transitive dependencies.