CVE-2008-5518 — console
Fix: apache/geronimo@aa0c2c2CVE-2008-5518 is a Path Traversal vulnerability in org.apache.geronimo.plugins:console. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.geronimo.plugins:console — see the affected versions and patch details below.
Apache Geronimo Application Server multiple directory traversal vulnerabilities
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.geronimo.plugins:consoleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Multiple directory traversal vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 on Windows allow remote attackers to upload files to arbitrary directories via directory traversal sequences in the (1) group, (2) artifact, (3) version, or (4) fileType parameter to console/portal//Services/Repository (aka the Services/Repository portlet); the (5) createDB parameter to console/portal/Embedded DB/DB Manager (aka the Embedded DB/DB Manager portlet); or the (6) filename parameter to the createKeystore script in the Security/Keystores portlet.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.geronimo.plugins:console | ≥ 2.1.0&&< 2.1.4 | 2.1.4org.apache.geronimo.plugins:console:2.1.4 |
Affected Products
geronimoapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Geronimo 2.1.3 - Multiple Directory Traversal Vulnerabilities
by DSecRG · Apr 16, 2009
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.geronimo.plugins:console, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.geronimo.plugins:console to 2.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-5518 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2008-5518 in your dependencies?
Find it across Maven, including transitive dependencies.