CVE-2007-6672 — jetty
CVE-2007-6672 is a Path Traversal vulnerability in org.mortbay.jetty:jetty. A fix is available for org.mortbay.jetty:jetty — see the affected versions and patch details below.
Mortbay Jetty Double Slash URI Information Disclosure Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.mortbay.jetty:jettyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Mortbay Jetty 6.1.5 and 6.1.6 allows remote attackers to bypass protection mechanisms and read the source of files via multiple / (slash) characters in the URI.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.mortbay.jetty:jetty | ≥ 6.1.5&&< 6.1.7 | 6.1.7org.mortbay.jetty:jetty:6.1.7 |
Affected Products
jettymortbay_jettyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.mortbay.jetty:jetty, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.mortbay.jetty:jetty to 6.1.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2007-6672 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2007-6672 in your dependencies?
Find it across Maven, including transitive dependencies.