NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2005-3747 — jetty

CVE-2005-3747 is a Information Exposure vulnerability in org.mortbay.jetty:jetty. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.mortbay.jetty:jetty — see the affected versions and patch details below.

Mortbay Jetty Discloses JSP Source Code

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.00%7.97%15.9%23.9%19.4%4.4%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.mortbay.jetty:jetty

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Unspecified vulnerability in Jetty before 5.1.6 allows remote attackers to obtain source code of JSP pages, possibly involving requests for .jsp files with URL-encoded backslash (%5C) characters. NOTE: this might be the same issue as CVE-2006-2758.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.mortbay.jetty:jettyall versions5.1.6org.mortbay.jetty:jetty:5.1.6

Affected Products

1 product · 240 configurations
Application
jettymortbay
≤ 5.1.5
163 versions
1.01.0.11.11.1.11.2.01.3.01.3.11.3.21.3.31.3.41.3.52.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-18571webappsphp

promise webpam 2.2.0.13 - Multiple Vulnerabilities

by LiquidWorm · Mar 7, 2012

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.mortbay.jetty:jetty, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.mortbay.jetty:jetty to 5.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2005-3747 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Unspecified vulnerability in Jetty before 5.1.6 allows remote attackers to obtain source code of JSP pages, possibly involving requests for .jsp files with URL-encoded backslash (`%5C`) characters. NOTE: this might be the same issue as CVE-2006-2758.
O3 Security · Impact-Aware SCA

Is CVE-2005-3747 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2005-3747: jetty — Fixed in 5.1.6