GHSA-xw73-rw38-6vjc is a medium-severity (CVSS 6.9) CWE-345 vulnerability in github.com/docker/docker. A fix is available for github.com/docker/docker — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-xw73-rw38-6vjc.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/docker/docker🐹github.com/moby/moby🐹github.com/moby/moby🐹github.com/docker/dockerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
The classic builder cache system is prone to cache poisoning if the image is built FROM scratch.
Also, changes to some instructions (most important being HEALTHCHECK and ONBUILD) would not cause a cache miss.
An attacker with the knowledge of the Dockerfile someone is using could poison their cache by making them pull a specially crafted image that would be considered as a valid cache candidate for some build steps.
For example, an attacker could create an image that is considered as a valid cache candidate for:
FROM scratch
MAINTAINER Pawel
when in fact the malicious image used as a cache would be an image built from a different Dockerfile.
In the second case, the attacker could for example substitute a different HEALTCHECK command.
Impact
23.0+ users are only affected if they explicitly opted out of Buildkit (DOCKER_BUILDKIT=0 environment variable) or are using the /build API endpoint (which uses the classic builder by default).
All users on versions older than 23.0 could be impacted. An example could be a CI with a shared cache, or just a regular Docker user pulling a malicious image due to misspelling/typosquatting.
Image build API endpoint (/build) and ImageBuild function from github.com/docker/docker/client is also affected as it the uses classic builder by default.
Patches
Patches are included in Moby releases:
- v25.0.2
- v24.0.9
- v23.0.10
Workarounds
- Use
--no-cacheor use Buildkit if possible (DOCKER_BUILDKIT=1, it's default on 23.0+ assuming that the buildx plugin is installed). - Use
Version = types.BuilderBuildKitorNoCache = trueinImageBuildOptionsforImageBuildcall.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/docker/docker | all versions | 24.0.9go get github.com/docker/docker@v24.0.9 |
| 🐹Go | github.com/moby/moby | all versions | 24.0.9go get github.com/moby/moby@v24.0.9 |
| 🐹Go | github.com/moby/moby | ≥ 25.0.0&&< 25.0.2 | 25.0.2go get github.com/moby/moby@v25.0.2 |
| 🐹Go | github.com/docker/docker | ≥ 25.0.0&&< 25.0.2 | 25.0.2go get github.com/docker/docker@v25.0.2 |
Affected Products
mobymobyprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/docker/docker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/docker/docker to 24.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xw73-rw38-6vjc is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat rates this as a Moderate impact since attack complexity is quite high. There are multiple conditions which are required: dockerfile is configured to use a non-default setting, attacker must be aware of this information, and they must have the ability to craft a malicious cache.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ceph Storage 7.1 | rhceph/grafana-rhel9:11.5.2-5 | RHSA-2025:9340 |
| Red Hat Ceph Storage 8.1 | rhceph/grafana-rhel9:11.6.2-4 | RHSA-2025:11749 |
Frequently Asked Questions
Is GHSA-xw73-rw38-6vjc in your dependencies?
Find it across Go, including transitive dependencies.