Linkdave Missing Authentication on REST and WebSocket endpointsGHSA-xv8g-fj9h-6gmv
Fix: shi-gg/linkdave@0f9a00dGHSA-xv8g-fj9h-6gmv is a security vulnerability in github.com/shi-gg/linkdave. A fix is available for github.com/shi-gg/linkdave — see the affected versions and patch details below.
Real-World Exposure
github.com/shi-gg/linkdaveReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
The linkdave server does not enforce authentication on its REST and WebSocket routes in versions prior to 0.1.5.
Impact
An attacker with network access to the server port can:
- Connect to the WebSocket endpoint (
/ws) and receive a validsession_idin theOpReadyresponse. - Use that session to invoke all REST player controls on any guild corresponding to their session id[1].
- Enumerate server statistics and runtime information via the unauthenticated
/statsendpoint (still public after the fix).
[1] If on >=0.1.0, attackers are restricted to creating, controlling and deleting players created within their own session ID.
Vulnerable Routes
The following routes were entirely unauthenticated in >= 0.0.1, < 0.1.5:
| Method | Path | Description |
|---|---|---|
POST | /sessions/{session_id}/players/{guild_id}/play | Start audio playback |
POST | /sessions/{session_id}/players/{guild_id}/pause | Pause playback |
POST | /sessions/{session_id}/players/{guild_id}/resume | Resume playback |
POST | /sessions/{session_id}/players/{guild_id}/stop | Stop playback |
POST | /sessions/{session_id}/players/{guild_id}/seek | Seek to position |
PATCH | /sessions/{session_id}/players/{guild_id}/volume | Set volume |
DELETE | /sessions/{session_id}/players/{guild_id} | Disconnect from voice channel |
GET | /ws | WebSocket event stream |
Patches
Update to 0.1.5.
- image: ghcr.io/shi-gg/linkdave:0.1.4
+ image: ghcr.io/shi-gg/linkdave:latest
or
docker pull ghcr.io/shi-gg/linkdave:latest
After upgrading, set the LINKDAVE_PASSWORD environment variable to a strong secret value. If this variable is left unset, the server will still accept all connections without authentication even on >= 0.1.5.
Server configuration (e.g. compose.yml):
environment:
LINKDAVE_PASSWORD: ${LINKDAVE_PASSWORD}
echo "LINKDAVE_PASSWORD=$(openssl rand -hex 16)" >> .env
To restart the stack, run
docker compose up -d
TypeScript client (0.1.5+):
The client automatically handles authentication. Pass the password when constructing the client:
const linkdave = new LinkDaveClient({
nodes: [
{
name: "main",
url: process.env.LINKDAVE_URI,
password: process.env.LINKDAVE_PASSWORD
}
]
});
Workarounds
If upgrading is not immediately possible, restrict network access to the server's port using a firewall so it is only accessible from trusted internal IP addresses.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/shi-gg/linkdave | all versions | 0.1.5go get github.com/shi-gg/linkdave@v0.1.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/shi-gg/linkdave, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/shi-gg/linkdave to 0.1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xv8g-fj9h-6gmv is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-xv8g-fj9h-6gmv in your dependencies?
Find it across Go, including transitive dependencies.