NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

appium-desktop OS Command Injection vulnerabilityGHSA-xq6j-x8pq-g3gr

CRITICALFix: appium/appium-desktop@12a988a

GHSA-xq6j-x8pq-g3gr is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in appium-desktop. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.

Also known asCVE-2023-2479
Published
Updated
Affected
1 pkg
Patched
See advisory
Exploits
1 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-xq6j-x8pq-g3gr.

EPSS Exploitation Probability

via FIRST.org ↗
22.0%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.62%33.7%66.9%100.0%93.3%22.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
appium-desktopnpm
21downloads / week

Description

OS Command Injection in GitHub repository appium/appium-desktop prior to v1.22.3-4.

Affected Packages

1 total
EcosystemPackageVulnerable rangeFix
📦npmappium-desktopall versionsNo fix

Affected Products

1 product · 1 configurations
Application
appium-desktopappium
< 1.22.3-4
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for appium-desktop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Remediation status

    The records we use list no patched version of appium-desktop for GHSA-xq6j-x8pq-g3gr. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.

  3. Mitigate without a patch

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect GHSA-xq6j-x8pq-g3gr

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-xq6j-x8pq-g3gr -u https://target
Template
Appium Desktop Server - Remote Code Execution
Severity
critical
Impact
Unauthenticated attackers can exploit OS command injection through the url parameter to execute arbitrary system commands and completely compromise Appium Desktop Server installations.
Remediation
Fixed in v1.22.3-4

Template by ProjectDiscovery nuclei-templates (zn9988), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

appium-desktop v1.14.1 and prior is vulnerable to OS Command Injection.
O3 Security · Impact-Aware SCA

Is GHSA-xq6j-x8pq-g3gr in your dependencies?

Find it across npm, including transitive dependencies.

appium-desktop OS Command Injection vulnerability