NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀 crates.io
Not in CISA KEV

Miscomputed sha2 results when using AVX2 backendGHSA-xpww-g9jx-hp8r

Fix: RustCrypto/hashes#314

GHSA-xpww-g9jx-hp8r is a Broken Cryptographic Algorithm vulnerability in sha2. A fix is available for sha2 — see the affected versions and patch details below.

Also known asCVE-2021-45696GHSA-fc7x-2cmc-8j2gRUSTSEC-2021-0100
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.44%0.89%1.33%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🦀sha2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

The v0.9.7 release of the sha2 crate introduced a new AVX2-accelerated backend which was automatically enabled for all x86/x86_64 CPUs where AVX2 support was autodetected at runtime.

This backend was buggy and would miscompute results for long messages (i.e. messages spanning multiple SHA blocks).

The crate has since been yanked, but any users who upgraded to v0.9.7 should immediately upgrade to v0.9.8 and recompute any hashes which were previously computed by v0.9.7.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iosha2≥ 0.9.7&&< 0.9.80.9.8cargo update -p sha2 --precise 0.9.8

Affected Products

1 product · 1 configurations
Application
sha2sha2_project
1 version
0.9.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sha2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sha2 to 0.9.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xpww-g9jx-hp8r is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The v0.9.7 release of the `sha2` crate introduced a new AVX2-accelerated backend which was automatically enabled for all x86/x86_64 CPUs where AVX2 support was autodetected at runtime. This backend was buggy and would miscompute results for long messages (i.e. messages spanning multiple SHA blocks). The crate has since been yanked, but any users who upgraded to v0.9.7 should immediately upgrade to v0.9.8 and recompute any hashes which were previously computed by v0.9.7.
O3 Security · Impact-Aware SCA

Is GHSA-xpww-g9jx-hp8r in your dependencies?

Find it across crates.io, including transitive dependencies.

Miscomputed sha2 results when using AVX2 backend