OpenMRS has Stored Velocity SSTI to RCE via ConceptReferenceRangeGHSA-xj4f-8jjg-vx4q
CRITICALFix: openmrs/openmrs-core@8d1c193GHSA-xj4f-8jjg-vx4q is a critical-severity (CVSS 9.1) Code Injection vulnerability in org.openmrs.api:openmrs-api. A fix is available for org.openmrs.api:openmrs-api — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-xj4f-8jjg-vx4q.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.openmrs.api:openmrs-api☕org.openmrs.api:openmrs-apiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The ConceptReferenceRangeUtility.evaluateCriteria() method in OpenMRS Core
evaluates database-stored criteria strings as Apache Velocity templates without any sandbox configuration. The VelocityEngine is initialized with only logging properties and noSecureUberspector, leaving the default UberspectImpl in place, which allows
unrestricted Java reflection through template expressions.
A user with the Manage Concepts privilege can store a malicious Velocity template
expression in a concept's reference range criteria field. This payload is then executed
automatically whenever a user or API call validates an observation against the affected
concept. The Velocity context exposes $patient (the Person / Patient object), $obs (the Obs object), and $fn (the ConceptReferenceRangeUtility instance with access to the full OpenMRS service layer).
Persistent Remote Code Execution: The payload persists in the concept_reference_range database table (VARCHAR 65535). A single compromised concept for a common clinical measurement executes the payload on every subsequent observation validation across all users, API clients, and integrations in the facility.
Privilege Escalation: The Manage Concepts privilege is a content-management function, defined as "Able to add/edit/delete concept entries", not an administrative privilege. Multiple non-admin staff per facility typically hold this privilege. The attacker escalates from concept dictionary management to arbitrary code execution as the Tomcat application server process.
PHI Exfiltration: The Velocity context objects directly expose patient data without requiring OS-level RCE.
Patches
This is fixed in 2.8.6 and 2.7.9 as well as future versions.
Workarounds
Ensure the Manage Concepts privilege is restricted to only authorized users and carefully audit any ConceptReferenceRanges in the database.
Resources
https://github.com/openmrs/openmrs-core/commit/8d1c193 https://www.machinespirits.com/advisory/1e8430/
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.openmrs.api:openmrs-api | ≥ 2.7.0&&< 2.7.9 | 2.7.9org.openmrs.api:openmrs-api:2.7.9 |
| ☕Maven | org.openmrs.api:openmrs-api | ≥ 2.8.0&&< 2.8.6 | 2.8.6org.openmrs.api:openmrs-api:2.8.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.openmrs.api:openmrs-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.openmrs.api:openmrs-api to 2.7.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xj4f-8jjg-vx4q is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-xj4f-8jjg-vx4q in your dependencies?
Find it across Maven, including transitive dependencies.