Moodle Vulnerable to Reflected Cross-site ScriptingGHSA-xhfx-rm8q-c3xv
MEDIUMFix: moodle/moodle@dc9de7bGHSA-xhfx-rm8q-c3xv is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It was found in Moodle before version 4.0.0-beta that some search inputs were vulnerable to reflected Cross-site Scripting (XSS) due to insufficient escaping of search queries.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.10&&< 4.0.0-beta | 4.0.0-betacomposer require moodle/moodle:^4.0.0-beta |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.0.0-beta or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xhfx-rm8q-c3xv is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-xhfx-rm8q-c3xv in your dependencies?
Find it across Packagist, including transitive dependencies.