OpenClaw's shell startup env injection bypasses system.run allowlist intent (RCE class)GHSA-xgf2-vxv2-rrmg
HIGHFix: openclaw/openclaw@c2c7114GHSA-xgf2-vxv2-rrmg is a high-severity (CVSS 7.5) OS Command Injection vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-xgf2-vxv2-rrmg.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
system.run environment sanitization allowed shell-startup env overrides (HOME, ZDOTDIR) that can execute attacker-controlled startup files before allowlist-evaluated command bodies.
Affected Packages / Versions
- Package:
openclaw(npm) - Affected:
<= 2026.2.21-2(latest published vulnerable version) - Planned patched version:
>= 2026.2.22
Technical Details
In affected versions:
- Env sanitization blocked many dangerous keys, but not startup-sensitive override keys (
HOME,ZDOTDIR) in host exec env paths. - Shell-wrapper analysis for allowlist mode models command bodies, but not shell startup side effects.
- Runtime execution used sanitized env, so attacker-provided startup-key overrides could run hidden startup payloads first.
Observed exploit vectors:
HOME+bash -lc+ malicious.bash_profileZDOTDIR+zsh -c+ malicious.zshenv
Fix Commit(s)
c2c7114ed39a547ab6276e1e933029b9530ee906
Release Process Note
patched_versions is pre-set to the planned next release (>= 2026.2.22). After the npm release is published, this advisory can be published directly.
OpenClaw thanks @tdjackey for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.2.22npm install openclaw@2026.2.22 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xgf2-vxv2-rrmg is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-xgf2-vxv2-rrmg in your dependencies?
Find it across npm, including transitive dependencies.