Microweber Stored Cross-site Scripting before v1.2.20GHSA-xg72-6c83-ghh4
MEDIUMFix: microweber/microweber@d35e691GHSA-xg72-6c83-ghh4 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in microweber/microweber. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for microweber/microweber — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
microweber/microweberReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.2.21.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | microweber/microweber | all versions | 1.2.20composer require microweber/microweber:^1.2.20 |
Affected Products
microwebermicroweberResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for microweber/microweber, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update microweber/microweber to 1.2.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xg72-6c83-ghh4 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-xg72-6c83-ghh4 in your dependencies?
Find it across Packagist, including transitive dependencies.