Zendframework Remote Address Spoofing Vector in `Zend\Http\PhpEnvironment\RemoteAddress`GHSA-xffp-6w68-4775
HIGHFix: zendframework/zendframework@bb67844GHSA-xffp-6w68-4775 is a high-severity (CVSS 7.5) vulnerability in zendframework/zendframework. A fix is available for zendframework/zendframework — see the affected versions and patch details below.
Real-World Exposure
zendframework/zendframeworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The Zend\Http\PhpEnvironment\RemoteAddress class provides features around detecting the internet protocol (IP) address for an incoming proxied request via the X-Forwarded-For header, taking into account a provided list of trusted proxy server IPs. Prior to 2.2.5, the class was not taking into account whether or not the IP address contained in PHP's $_SERVER['REMOTE_ADDR'] was in the trusted proxy server list.
The IETF draft specification indicates that if $_SERVER['REMOTE_ADDR'] is not a trusted proxy, it must be considered the originating IP address, and the value of X-Forwarded-For must be disregarded.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zendframework | ≥ 2.2.0&&< 2.2.5 | 2.2.5composer require zendframework/zendframework:^2.2.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zendframework to 2.2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xffp-6w68-4775 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-xffp-6w68-4775 in your dependencies?
Find it across Packagist, including transitive dependencies.