silverstripe/subsites Unsafe SQL Query Construction (Safe Data Source)GHSA-xc69-p8fc-m6m5
HIGHFix: silverstripe/silverstripe-subsites@bf2c81dGHSA-xc69-p8fc-m6m5 is a high-severity (CVSS 8.8) vulnerability in silverstripe/subsites. A fix is available for silverstripe/subsites — see the affected versions and patch details below.
Real-World Exposure
silverstripe/subsitesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
There is a low level potential SQL injection vulnerability in the silverstripe/subsites module has been identified and fixed in version 2.1.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/subsites | ≥ 2.0.0&&< 2.1.1 | 2.1.1composer require silverstripe/subsites:^2.1.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/subsites, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/subsites to 2.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xc69-p8fc-m6m5 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is GHSA-xc69-p8fc-m6m5 in your dependencies?
Find it across Packagist, including transitive dependencies.