NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Insufficiently Protected Credentials in RequestsGHSA-x84v-xcm2-53pg

HIGHFix: requests/requests#4718

GHSA-x84v-xcm2-53pg is a high-severity (CVSS 7.5) CWE-522 vulnerability in requests. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for requests — see the affected versions and patch details below.

Also known asCVE-2018-18074PYSEC-2018-28
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
0.00%3.21%6.42%9.62%0.2%6.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍requests

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The Requests package through 2.19.1 before 2018-09-14 for Python sends an HTTP Authorization header to an http URI upon receiving a same-hostname https-to-http redirect, which makes it easier for remote attackers to discover credentials by sniffing the network.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIrequestsall versions2.20.0pip install --upgrade 'requests==2.20.0'

Affected Products

6 products · 9 configurations
OS
ubuntu linuxcanonical
4 versions
14.0416.0418.0418.10
OS
leapopensuse
1 version
15.1
Application
requestspython
< 2.20.0
range
OS
enterprise linux desktopredhat
1 version
7.0
OS
enterprise linux serverredhat
1 version
7.0
OS
enterprise linux workstationredhat
1 version
7.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for requests, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update requests to 2.20.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x84v-xcm2-53pg is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
Red Hat Ansible Tower 3.5 for RHEL 7ansible-tower-35/ansible-tower:3.5.6-1RHBA-2020:1539
Red Hat Ansible Tower 3.6 for RHEL 7ansible-tower-36/ansible-tower:3.6.4-1RHBA-2020:1540
Red Hat Enterprise Linux 7python-requests-0:2.6.0-5.el7RHSA-2019:2035
Red Hat Enterprise Linux 7python-pip-0:9.0.3-7.el7_7RHSA-2020:0850
Red Hat Enterprise Linux 7python-virtualenv-0:15.1.0-4.el7_7RHSA-2020:0851
Red Hat Enterprise Linux 7python-pip-0:9.0.3-7.el7_8RHSA-2020:2068
Red Hat Enterprise Linux 7python-virtualenv-0:15.1.0-4.el7_8RHSA-2020:2081
Red Hat Enterprise Linux 8python27:2.7-8020020200117110429.90f98d4fRHSA-2020:1605

Frequently Asked Questions

The Requests package through 2.19.1 before 2018-09-14 for Python sends an HTTP Authorization header to an http URI upon receiving a same-hostname https-to-http redirect, which makes it easier for remote attackers to discover credentials by sniffing the network.
O3 Security · Impact-Aware SCA

Is GHSA-x84v-xcm2-53pg in your dependencies?

Find it across PyPI, including transitive dependencies.

Insufficiently Protected Credentials in Requests (High 7.5)