RKE2 allows privilege escalation in Windows nodes due to Insecure Access Control ListsGHSA-x7xj-jvwp-97rv
CRITICALGHSA-x7xj-jvwp-97rv is a critical-severity (CVSS 9.1) vulnerability in github.com/rancher/rke2. A fix is available for github.com/rancher/rke2 — see the affected versions and patch details below.
Real-World Exposure
github.com/rancher/rke2🐹github.com/rancher/rke2🐹github.com/rancher/rke2🐹github.com/rancher/rke2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A vulnerability has been identified whereby RKE2 deployments in Windows nodes have weak Access Control Lists (ACL), allowing BUILTIN\Users or NT AUTHORITY\Authenticated Users to view or edit sensitive files which could lead to privilege escalation.
The affected files include binaries, scripts, configuration and log files:
C:\etc\rancher\node\password
C:\var\lib\rancher\rke2\agent\logs\kubelet.log
C:\var\lib\rancher\rke2\data\v1.**.**-rke2r*-windows-amd64-*\bin\*
C:\var\lib\rancher\rke2\bin\*
This vulnerability is exclusive to RKE2 in Windows environments. Linux environments are not affected by it.
Please consult the associated MITRE ATT&CK - Technique - Exploitation for Privilege Escalation for further information about this category of attack.
Patches
Patched versions include RKE2 1.31.0, 1.30.2, 1.29.6, 1.28.11 and 1.27.15.
Workarounds
Users are advised to do a fresh install of their RKE2 Windows nodes using a patched RKE2 version. When that is not possible, users can enforce stricter ACLs for all sensitive files affected by this Security Advisory running this PowerShell script as an Administrator on each node.
References
For more information
If you have any questions or comments about this advisory:
- Reach out to the SUSE Rancher Security team for security related inquiries.
- Open an issue in the Rancher repository.
- Verify with our support matrix and product support lifecycle.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/rancher/rke2 | ≥ 1.27.0&&< 1.27.15 | 1.27.15go get github.com/rancher/rke2@v1.27.15 |
| 🐹Go | github.com/rancher/rke2 | ≥ 1.28.0&&< 1.28.11 | 1.28.11go get github.com/rancher/rke2@v1.28.11 |
| 🐹Go | github.com/rancher/rke2 | ≥ 1.29.0&&< 1.29.6 | 1.29.6go get github.com/rancher/rke2@v1.29.6 |
| 🐹Go | github.com/rancher/rke2 | ≥ 1.30.0&&< 1.30.2 | 1.30.2go get github.com/rancher/rke2@v1.30.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/rancher/rke2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/rancher/rke2 to 1.27.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x7xj-jvwp-97rv is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is GHSA-x7xj-jvwp-97rv in your dependencies?
Find it across Go, including transitive dependencies.