Harvest Chosen vulnerable to Cross-site ScriptingGHSA-x5q4-m45m-fm94
MEDIUMFix: harvesthq/chosen#2997GHSA-x5q4-m45m-fm94 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in harvesthq/chosen. A fix is available for harvesthq/chosen — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-x5q4-m45m-fm94.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
harvesthq/chosenReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability, which was classified as problematic, has been found in Harvest Chosen up to 1.8.6. Affected by this issue is the function AbstractChosen of the file coffee/lib/abstract-chosen.coffee. The manipulation of the argument group_label leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.8.7 is able to address this issue. The name of the patch is 77fd031d541e77510268d1041ed37798fdd1017e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216956.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | harvesthq/chosen | all versions | 1.8.7composer require harvesthq/chosen:^1.8.7 |
Affected Products
chosengetharvestDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for harvesthq/chosen, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update harvesthq/chosen to 1.8.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x5q4-m45m-fm94 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-x5q4-m45m-fm94 in your dependencies?
Find it across Packagist, including transitive dependencies.