Ibis PyArrow dependency allows arbitrary code execution when loading a malicious data fileGHSA-x563-6hqv-26mr
Fix: ibis-project/ibis@0fa1e5dGHSA-x563-6hqv-26mr is a remote code execution vulnerability in ibis-framework. A fix is available for ibis-framework — see the affected versions and patch details below.
Real-World Exposure
ibis-frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files). This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.
Note that Ibis itself makes extremely limited use of pyarrow.parquet.read_table:
read_tableis used in tests, where the input file is entirely controlled by the Ibis developersread_tableis used in theibis/examples/__init__.pyas a fallback for backends that don't support reading Parquet directly. Parquet data used inibis.examplesare also managed by the Ibis developers. This Parquet data is generated from CSV files and SQLite databases.- The Pandas and Dask backends both use PyArrow to read Parquet files and are therefore affected.
Ibis does not make use of APIs that directly read from either Arrow IPC files or Feather files.
Patches
Ibis imports the pyarrow_hotfix package wherever pyarrow is used, as of version 7.1.0.
Upgrading to Arrow 14.0.1 is also a possible solution, starting in Ibis 7.1.0.
Workarounds
Install pyarrow_hotfix and run import pyarrow_hotfix ahead of any and all import ibis statements.
For example:
import ibis
becomes
import pyarrow_hotfix
import ibis
References
https://www.cve.org/CVERecord?id=CVE-2023-47248 https://nvd.nist.gov/vuln/detail/CVE-2023-47248
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ibis-framework | all versions | 7.1.0pip install --upgrade 'ibis-framework==7.1.0' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ibis-framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ibis-framework to 7.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x563-6hqv-26mr is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is GHSA-x563-6hqv-26mr in your dependencies?
Find it across PyPI, including transitive dependencies.